Welcome to the Panopto Community

Please note: All new registrants to the Panopto Community Forum must be approved by a forum moderator or admin. As such, if you navigate to a feature that is members-only, you may receive an error page if your registration has not yet been approved. We apologize for any inconvenience and are approving new members as quickly as possible.

Panopto SOAP APIs : response code returned as 202 (accepted) but no results

edited June 17 in API

Hi Panopto Support,

We are writing the java client code for Panopto SOAP APIs, while accessing the APIs, we are always getting the response code as 202(accepted) but no results are returned. I want to confirm whether the below steps are correct,

Step 1: Generated Authentication code Using the below Logic:

authCode = SHA1(UserKey + "@" + domainName.ToLower() + "|" + applicationKey.ToLower())

**I guess UserKey is same as Panopto cloud’s username.

ApplicationKey got from Identity Provider page (ProviderId), 

Step 2: And tried to Read the List of Recorders available (To get the recorderId), 

URL Used: https://domainName/Panopto/PublicAPI/4.2/RemoteRecorderManagement.svc

Ssl-verify = false

Set the content type as "text/xml; charset=utf-8";

Set the SOAPAction as http://domainName/IRemoteRecorderManagement/ListRecorders. And also tried with SOAPAction = ListRecorders

Set the http method as POST

Message Body:

<Envelope xmlns="http://schemas.xmlsoap.org/soap/envelope/">

  <Body>

        <ListRecorders xmlns="https://domainName/">

      <!-- Optional -->

      <auth>

        <AuthCode>*****</AuthCode>   -> Used the AuthCode generated at Step:1        - 

        <Password>*****</Password>

        <UserKey>*****</UserKey>

      </auth>

      <!-- Optional -->

      <pagination>

        <MaxNumberResults>10</MaxNumberResults>

        <PageNumber>1</PageNumber>

      </pagination>

      <sortBy>name</sortBy>

    </ListRecorders>

  </Body>

</Envelope>

I tried other APIs also, we are always getting the response code as 202 (accepted) with no error and also no result. 

Answers

  • Joe MalmstenJoe Malmsten Panopto Employee

    Hi,

    Are you using internal or external users(users made from an Identity provider)? If you are using an internal user, you should not send the auth code, just send the user name and password. If you are using an external user, then send the user name (with the id provider pre-pended like <identityProvider>/<UserKey>) and the auth code (remove the password parameter).

    Please also make sure to change the SOAP action to be SOAPAction: "http://tempuri.org/IRemoteRecorderManagement/ListRecorders"

    Here is an example of what your SOAP request should look like, if you replace the fields with proper information

    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:tem="http://tempuri.org/" xmlns:pan="http://schemas.datacontract.org/2004/07/Panopto.Server.Services.PublicAPI.V40">
       <soapenv:Header/>
       <soapenv:Body>
          <tem:ListRecorders>
             <!--Optional:-->
             <tem:auth>
                <!--Optional:-->
                <pan:AuthCode>*****</pan:AuthCode>
                <!--Optional:-->
                <pan:Password>*****</pan:Password>
                <!--Optional:-->
                <pan:UserKey>****</pan:UserKey>
             </tem:auth>
             <!--Optional:-->
             <tem:pagination>
                <!--Optional:-->
                <pan:MaxNumberResults>10</pan:MaxNumberResults>
                <!--Optional:-->
                <pan:PageNumber>0</pan:PageNumber>
             </tem:pagination>
             <!--Optional:-->
             <tem:sortBy>Name</tem:sortBy>
          </tem:ListRecorders>
       </soapenv:Body>
    </soapenv:Envelope>
    


    Hope this helps,

    Joe

  • Thank You Joe ,

    I Had a discussion with Panopto Support also.

    "http://tempuri.org/IRemoteRecorderManagement/ListRecorders" was the issue. Now it's working.

    Regards,

    Karthick

Sign In or Register to comment.