Welcome to the Panopto Community

Please note: All new registrants to the Panopto Community Forum must be approved by a forum moderator or admin. As such, if you navigate to a feature that is members-only, you may receive an error page if your registration has not yet been approved. We apologize for any inconvenience and are approving new members as quickly as possible.
Options

REST API configuration for Postman desktop app on Linux

edited January 15 in API

Dear community,

I'm new to Panopto as my university bought a cloud license last month. I've been trying to configure Postman app on Linux to make some API requests, but I can't seem to make it work. I managed to get authorization tokens, but I'm still getting 401 - Unauthorized responses to whatever query I make.

Reading this forum, I've seen that this usually depends on the API client type chosen in Panopto - a server-side web application has lots of authorization issues, while the user-based applications (with admin accounts) shouldn't. Well, in my case the problem persists.

Here are my configurations:

1) Server-side web application

2) User-Based application

I want to reiterate: in both cases I manage to get an authorization token, so everything seems to be working in this configuration. However, whatever API query I make, I get this result:

Can you help me?

Thank you!

Tagged:

Answers

  • Options
    Kevin BaumKevin Baum Panopto Employee

    Hi Claudio,

    It's possible that the user you are using does not have the correct permission to access the object (folder or video) you are calling the API for, with that error message. Can you verify that your user has access to the folder in your example (they would need to have permission to view the folder)?

    I would also verify that the Authorization header was sent with the correct access token in the Postman request and that you've set that token in the Authorization section of the request. One other note is that the access tokens will only last for 1 hour before a new one is needed. If the requests have worked previously but stopped working, it's possible that you just need a new access token.

    If you can verify that the user has permission and a valid access token is being sent in the request, I would ask if you can have your POC open a support ticket with Panopto on your behalf, and I can collect some additional information from you to continue to investigate this further.

    If you have any other questions, please let me know.

    Thanks,

    Kevin

  • Options

    Dear Kevin,

    Thanks for your reply!

    I'm using my administrator account, so it should have all privileges to access everything. Also, the authorization token was indeed included in my request:

    I'll have my POC open the support request then, thanks!

  • Options

    Hey, I got your message. I tried to log into the app earlier and activated my authorization token, but I still couldn't get in. Turns out, I needed to adjust my account privileges - it wasn't the token's fault. I've checked and updated my admin account, and now it has all the necessary privileges. I also made sure to include the authorization token in my request. I'm always open to different perspectives when troubleshooting, especially when AI came up. https://andersenlab.com/services/artificial-intelligence Thanks again for your help!

Sign In or Register to comment.