Welcome to the Panopto Community

Please note: All new registrants to the Panopto Community Forum must be approved by a forum moderator or admin. As such, if you navigate to a feature that is members-only, you may receive an error page if your registration has not yet been approved. We apologize for any inconvenience and are approving new members as quickly as possible.

API creation issue


I’m a developer for Temple and I’m trying to setup an oauth web application, but I’m having trouble with the initial redirect to the login page. I get this response:

{"viewModel":{"errorMessage":"The client application is not known or is not authorized.","requestId":"abbd8345-bee2-4fd5-ad63-12dea622ba8b","siteUrl":"https://temple.hosted.panopto.com/Panopto/oauth2/","siteName":"","currentUser":null,"logoutUrl":"https://temple.hosted.panopto.com/Panopto/oauth2/logout","custom":{"errorDefaultProcessingRequestError":"Error processing request","oAuth2ErrorRequestId":"Request Id"}},"view":"error","logoUrl":"/Panopto/ContentCache/637626529931041344/_branding/6b26fc5e-a3a9-4c86-849b-ad6400ec1d30/637626526509216718_largelogo.png"}

From this URL:

https://temple.hosted.panopto.com/Panopto/oauth2/connect/authorize?client_id=myclientid&scope=openid profile api offline_access&redirect_uri=https://np-sites.temple.edu/wp-content/plugins/presentation-dropbox/views/oauthCallback&response_type=code&nonce=0a571642ed

I’ve triple checked my settings on the Panopto Client API page, and I have the correct CORS origin, the redirect URL matches what I’m sending, and the client ID was copy and pasted from the API settings page to my app’s settings (it’s listed under my name in the settings). Also, should the redirect_uri parameter be uri encoded? I tried it that way too and go the same response as above.

Any thoughts on what’s going on?




  • Options

    A note to make as well the site I am testing is WordPress and internal app behind our Firewall, though it is failing before we can even log in to Panopto

  • Options
    Kevin BaumKevin Baum Panopto Employee

    Hi Gino,

    I took a look at our internal logs, and it appears that the client type you are using is a Hybrid Web Application API Client. For a Hybrid Web Application client, the response_type value should be code token instead of code .

    Can you please try changing the response_type in the query parameters, and see if that works for you?

    Please let me know if you have any questions.



  • Options

    Thanks Kevin! will test and get back to you

Sign In or Register to comment.