Welcome to the Panopto Community

Please note: All new registrants to the Panopto Community Forum must be approved by a forum moderator or admin. As such, if you navigate to a feature that is members-only, you may receive an error page if your registration has not yet been approved. We apologize for any inconvenience and are approving new members as quickly as possible.

Panopto desktop recorder error

One of our instructors is trying to record a session on his Mac. He is getting this error:

Value is Nil:

self.primary.captureGraph =

Requested action cannot be taken under the current recorder state.

We tried turning off his FaceTime HD Camera and it's still giving him the error

Answers

  • Cait McCabeCait McCabe Administrator

    Hi Cindy,

    I spoke with another member of my team, and we believe this is a matter for our Support team. I went to submit a support ticket on your behalf, and it looks like there's already one open for this. A member of the Support team should be in contact soon.

    Please let me know if you have any more issues, I'm happy to help.

    Best wishes,

    Cait

  • Hi I also have this error (one one Mac but not another - I wondered if there was an update?)

  • Andrew BortsAndrew Borts New Member

    Hi everyone! I had a faculty member report the same problem at UNLV. She's running MacOS Mojave 10.14. I attached the screen shot of what she sent to our help desk. She just installed the software, so I suggested rebooting first just to rule that out.


  • Hi Panopto team! I am having the exact same problem with two different computers (OS 10.13 and OS 10.15) and nobody seems to have an answer? Could you help please?

  • Cait McCabeCait McCabe Administrator

    Hi @Andrew Borts,

    It looks like you were able to work with our Support team on this issue and get it worked out, which is great! If you have any additional questions, please feel free to ask - we're always happy to help!

    Best Wishes,

    Cait

  • Cait McCabeCait McCabe Administrator

    Hi @Lucie Morisset and @Neal Harman,

    This could be an issue if you haven't given the Panopto application access to your microphone and camera, so I would recommend checking this, first. If you go to System Preferences, select Security and Privacy. Then, select the lock icon in the bottom left corner so you can "unlock" and make changes. On the Camera and Microphone tabs, make sure you have Panopto selected so that the Panopto application has been given access to use both the microphone and camera.

    If either of you are still having this issue when using the desktop recorder, please send me a message that includes your organization and I can contact our Support team for you.

    Best wishes,

    Cait

  • Any new information on this? I'm having the same problem on macOS 10.15. Permission/access is enabled for Panopto in System Preferences - Security and Privacy.

  • Cait McCabeCait McCabe Administrator

    Hi @Matt Hayward,

    If you do have permissions granted and are still experiencing this issue, this would definitely be an issue for our Support team. To expedite this matter, I'll go ahead and get a Support ticket started for you and let your local Panopto administrator know that you're having this issue. Please keep an eye out for correspondence regarding this matter.

    If you have any additional questions, please feel free to ask.

    Best wishes,

    Cait

  • For me it turns out that deleting an application called CamTwist Studio fixed it - so could be a software conflict issue.

    Regards

    Neal

  • I just figured it out, thanks for your input @Neal Harman!! I installed SnapCamera for Zoom meetings. Uninstalled that and it works.

    Not sure why Panopto is hindered by SnapCamera as Teams, FaceTime, iMovie, BB Collaborate, WebEx, Zoom, OBS, and QuickTime and other video applications have been working fine with it installed.

    For what it's worth none of my coworkers using SnapCamera with Macs have experienced the issue. Must just be a random bug that doesn't like my hardware configuration.

  • Cait McCabeCait McCabe Administrator

    @Neal Harman - thanks for the assist! @Matt Hayward - I'll go ahead and close the ticket that was opened for you, thanks for the update! I'll let them know that SnapCamera was the cause for you.

    Regards,

    Cait

Sign In or Register to comment.